GDL Objekt Editor

Der GDL Objekt Editor enthält alle zum Bearbeiten eines GDL-Objekts erforderlichen Steuerelemente.

Eine ausführliche Beschreibung der Scripting-Befehle und der Bearbeitung auf Objektebene finden Sie im GDL Referenzhandbuch (verfügbar über das ARCHICAD Hilfemenü).

GDL Objekt Editor öffnen

Zum Öffnen des GDL Objekt Editors führen Sie einen der folgenden Schritte durch:

Für ein platziertes Objekt: Wählen Sie das Objekt aus und verwenden Sie anschließend Ablage > Bibliotheken und Objekte > Objekt öffnen (oder wählen Sie den passenden Button in der Symbolleiste “GDL-Bibliothekselemente bearbeiten” aus).

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/OpenObject.png 

Für ein beliebiges Objekt (oder wenn kein platziertes Objekt ausgewählt ist): Verwenden Sie Ablage > Bibliotheken und Objekte > Objekt öffnen… und blättern Sie zum gewünschten Objekt.

Eine andere Möglichkeit, nach einem Objekt zu suchen, ist der Untertyp: Verwenden Sie den Befehl Objekt öffnen mit Subtype in der Symbolleiste GDL-Bibliothekselemente bearbeiten.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/EditGDLToolbar001.png 

Das daraufhin geöffnete Fenster (neuer Tab) ist der GDL-Objekteditor.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/GDLMasterWindow.png 

Verwenden Sie die Schaltflächen auf der linken Seite, um verschiedene Tabellen/Listen zum Bearbeiten (z. B. Details, Parameter, Bestandteile) innerhalb des GDL Objekt-Editors zu öffnen.

Die GDL-Script-Fenster (z. B. Beschreibungen, Parameter-Script) können auf zwei verschiedene Arten geöffnet werden.

Wenn Sie direkt auf die Schaltfläche klicken, erfolgt die Bearbeitung innerhalb des Master-Fensters.

Wenn Sie auf das Fenstersymbol neben dem Namen des Scripts klicken, wird ein separates Fenster geöffnet zum Eingeben oder Ändern des Scripts.

Von jedem dieser separaten Fenster aus können Sie mit dem Kontextmenü der Tab-Leiste ganz einfach zurück zum Master-Fenster navigieren:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/TabContext2.png 

“Nur-lesen”-Objekte aus einer Bibliothekencontainer-Datei

Um ein Objekt aus dem Bibliothekencontainer zu bearbeiten, müssen Sie den Container zunächst extrahieren. Ansonsten können die Angaben im Objekt-Editorfenster nur gelesen werden”.

Weitere Informationen finden Sie unter Bibliothekencontainer.

Themen in diesem Abschnitt:

Die Steuerungen des GDL-Objekt Editors werden in den folgenden Abschnitten beschrieben.

Objekt-Vorschau

Objekt Details

Kompatibilitätsoptionen (Nur für Entwickler)

Kompatibilitätsoptionen Tür/Fenster (Nur für Entwickler)

Parameter

Migration

Bestandteile

Beschreibungen

Script-Schaltflächen

Tastaturkürzel des GDL Script Fensters

2D-Symbol (graphisch)

2D-Symbol-Anzeige (Fragmente)

Vorschau

2D- und 3D-Ansichten des Objekts markieren

Fenster schließen und Änderungen sichern

Übereinstimmung zwischen 2D- und 3D-Beschreibungen

Objekt-Vorschau

Das Vorschaufenster kann in einem von fünf Formaten angezeigt werden.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/ObjectPreview.png 

Klicken Sie auf eine der Schaltflächen neben dem Fenster, um eine Anzeigeoption für das Vorschaubild auszuwählen: 2D-Symbol, 2D-Ansicht, Vorn, 3D und Vorschaubild.

Bei Verwendung der Vorn- oder 3D-Vorschau können Sie auf das Vorschaufenster klicken, um das Bild in 45-Grad-Schritten zu drehen.

Objekt Details

Objekt-Subtype: Zeigt den Subtype (Untertyp) des geöffneten Objekts an.

Sie können den Subtype eines Objekts ändern, indem Sie auf die Schaltfläche Subtype auswählen klicken und so das Dialogfenster Subtype Hierarchie aufrufen. Wenn Sie einem Objekt einen anderen Subtype zuweisen, ändert sich das Verhalten des Objekts und es werden die für den neuen Subtype erforderlichen Parameter und Funktionen hinzugefügt. Sie können z. B. ein einfaches Objekt in eine Lichtquelle umwandeln, indem Sie als Subtype Licht wählen.

Weitere Informationen finden Sie unter Dialogfenster Subtype Hierarchie (GDL Master-Fenster).

Als Subtype benutzen: Wenn Sie dieses Kästchen aktivieren, wird das Objekt als Vorlage gespeichert, die dann in der Liste der verfügbaren Subtypen erscheint. Diese Vorlage wird im Dialogfeld Subtype Hierarchie angezeigt, und alle neuen Objekte, die Sie diesem Subtype zuweisen, werden alle Parameter dieses Subtyps übernehmen.

Das Platzierbar-Kontrollkästchen ist standardmäßig aktiviert. Wenn Sie hier die Markierung aufheben, verhält sich das Objekt wie ein Makro. Wenn dieses Kästchen nicht aktiviert ist, bedeutet dies, dass

es in keinem der Werkzeugeinstellungen-Dialogfenster erscheint.

Sie es nicht direkt im Projekt platzieren können.

es nicht in eine archivierte Projektdatei aufgenommen werden kann.

Aber Sie können von anderen Objekten auf seine Scripte zugreifen.

Objekt-Informationsfelder

Die nächsten Bedienelemente sind relevant, wenn Sie das Bibliothekselement auf BIMcomponents freigeben wollen, oder wenn Sie beabsichtigen, Ihr eigenes Objekt kommerziell verfügbar zu machen. Außerdem wird Text, den Sie eingeben, berücksichtigt, wenn Sie die Suchfunktion zum Finden von Bibliothekselementen über einen Bibliothekselement-Einstellungsdialog verwenden.

Siehe Nach Bibliothekselementen suchen.

Bearbeiten Sie die folgenden Informationen nach Bedarf:

Geben Sie den Ersteller ein. (Wenn Sie diesen Eintrag leer lassen, wird der Name, den Sie zur Registrierung in BIMcomponents verwendet hatten, als Ersteller verwendet, nachdem das Objekt freigegeben wurde.)

Weisen Sie das Copyright zu. Hier stehen drei Optionen zur Verfügung:

Lizenzfreie Überlassung: Klicken Sie auf die Infotaste, um zu einer Website mit Details zu gelangen: http://creativecommons.org/publicdomain/zero/1.0/

Namensnennung – Keine Bearbeitung: Klicken Sie auf die Infotaste, um zu einer Website mit Details zu gelangen: http://creativecommons.org/licenses/by-nd/3.0/

Kommerziell: Verwenden Sie diese Art von Copyright, wenn Sie das Objekt über das Internet verkaufen möchten. Ein Objekt mit einem kommerziellen Copyright kann nicht für BIMcomponents freigegeben werden. Klicken Sie auf die Infotaste, um zu einer Website mit Details zu gelangen.

Passwort (verfügbar wenn das Copyright Namensnennung-Keine Bearbeitung” oder “Kommerziell” ist). Klicken Sie auf Passwort festlegen, um ein optionales Passwort zu definieren. Solche Objekte können frei betrachtet und heruntergeladen werden, der Benutzer kann jedoch das Objekt zum Editieren nicht öffnen oder sein Script ohne Passwort kopieren.

Beschreibung. Geben Sie eine optionale Beschreibung des Objektes ein. Dieser Text erscheint, wenn Sie auf die Infotaste im Einstellungsdialog klicken, sowie in BIM Komponenten, wenn das Objekt dort freigegeben wurde. Außerdem wird der Beschreibungstext, den Sie eingeben, berücksichtigt, wenn Sie die Suchfunktion zum Finden von Bibliothekselementen über einen Bibliothekselement-Einstellungsdialog verwenden.

Kompatibilitätsoptionen (Nur für Entwickler)

Das Dialogfenster Kompatibilitätsoptionen kann über die Detailseite des GDL Objekt-Editors aufgerufen werden; es betrifft die Größen der Elemente (Instanzen).

Anmerkung: Türen und Fenster haben unterschiedliche Bedienelemente im Details-Dialogfenster; lies hierzu den nächsten Abschnitt.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/CompatibilityOptions.png 

Verhalten der Abmaße des Objektes: Verwenden Sie diese Optionsfelder, um festzulegen, wie platzierte Objekte (Objektinstanzen) ihre Parameterwerte speichern sollen.

Verhältnis der aktuellen/voreingestellten A/B-Werte speichern: Bei platzierten Objekten werden Änderungen in den Standard-A- und/oder -B-Parametern entsprechend proportional geändert.

Feste Werte speichern: Platzierte Objekte werden nicht geändert, wenn die Standard-A/B-Parameter später geändert werden.

Kompatibilitätsstatus:

Migrationsobjekt (es gibt keine neue kompatible Version von diesem Objekt)

Immer in den Objekt-Einstellungen anzeigen

Diese Bedienelemente werden nur von Entwicklern verwendet, die mit ARCHICAD-Bibliotheksobjekten arbeiten. Dieses Kontrollkästchen kennzeichnet Objekte, die in neueren Bibliotheksversionen nicht automatisch neue Gegenstücke erhalten.

Fixpunkt auf Begrenzungsrahmen: Aktivieren Sie dieses Kästchen (falls anwendbar), um an den Rändern des 2D-Symbols des Bibliothekselements fünf Hotspots zu platzieren. Diese sind unabhängig von Hotspots, die im GDL-Skript des Elements definiert sind. Diese fünf Hotspots befinden sich an den vier Ecken und im Zentrum des Begrenzungsrahmens des Symbols. Der Standardfixpunkt für die Platzierung des Objekts im Projekt ist der untere linke Punkt von den fünf Punkten. Dies wird durch ein Rechteck angezeigt, das die Fangpunkte des 2D-Symbols im Werkzeugeinstellungen-Dialogfenster des Bibliothekselements hervorhebt. Hier können Sie auch den aktiven Fangpunkt ändern.

Falls die untere linke Ecke des Begrenzungsrahmens nicht als Standard-Fangpunkt verwendet werden soll, lassen Sie das Kontrollkästchen deaktiviert und definieren Sie die benötigten Fangpunkte im GDL-Script. In diesem Fall dient der erste im Script gefundene Fangpunkt als Standard-Fangpunkt.

Falls weder am Begrenzungsrahmen noch im GDL-Script Fangpunkte festgelegt wurden, werden Fangpunkte an den Begrenzungsrahmen des Bibliothekelements positioniert und als Standard-Fangpunkt verwendet.

Größe an 2D-Symbol anpassen: Aktivieren Sie dieses Kästchen, um die A- und B-Werte des aktuellen 2D-Symbols in die Standard-A- und -B-Felder des Masterfensters zu übertragen.

Kompatibilitätsoptionen Tür/Fenster (Nur für Entwickler)

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/CompatibilityOptionsWindow.png 

Abgeleitete Maße: Verwenden Sie die Bearbeitungsfelder in diesem Bereich des Dialogfensters, um die geometrische Beziehung zwischen der Wandöffnung und der Tür oder dem Fenster zu definieren. Verwenden Sie numerische GDL-Ausdrücke.

Nominale Rahmenstärke: Geben Sie hier die nominale Rahmenstärke ein.

Brüstung: Legen Sie hier die Brüstung fest.

Öffnung Übergröße: Geben Sie hier die Öffnungs-Übergröße relativ zu den Nominalgrößen (A und B) für Y+, Y- (oben und unten) und X+, X- (rechts und links) ein.

Darstellung der Ausrichtung: Verwenden Sie diese Steuerungselemente, um festzulegen, wie die Ausrichtung der Öffnung gezeigt werden soll (z. B. R für rechts und L für links).

Grundeinstellung: Klicken Sie diesen Button an, um die Orientierung der Tür-/Fensteröffnungen als Standard-Grundeinstellungen darzustellen.

Umgekehrt: Klicken Sie diesen Button an, um die Orientierung der Tür-/Fensteröffnungen umgekehrt als Standard-Grundeinstellungen darzustellen.

Individuell: Klicken Sie diesen Button an, um die Anzeige der Tür-/Fensteröffnungen-Orientierung zu personalisieren.

Kompatibilitätsstatus (Nur für Entwickler)

Migrationsobjekt (es gibt keine neue kompatible Version von diesem Objekt)

Immer in den Objekt-Einstellungen anzeigen

Diese Bedienelemente werden nur von Entwicklern verwendet, die mit ARCHICAD-Bibliotheksobjekten arbeiten. Dieses Kontrollkästchen kennzeichnet Objekte, die in neueren Bibliotheksversionen nicht automatisch neue Gegenstücke erhalten.

3D-Kontur ausstellen: Markieren Sie es, um die 3D Kontur des ausgewählten Tür/Fenster-Objekts zu zeigen oder zu verbergen (im Drahtmodell-Modus oder bei Verdeckten Kanten).

Parameter

Klicken Sie auf die Schaltfläche Paramete, um die Parameter des aktuellen Bibliothekselementes in dem Editierbereich anzuzeigen.

Suchparameter: Geben Sie eine Textzeichenfolge in dem Suchfeld ein, um einen beliebigen Teil dieser Zeichenfolge in den Spalten Variable, Name oder Wert zu finden. Der Cursor springt zur ersten gefundenen Instanz. Verwenden Sie die Schaltflächen Nächstes finden/Vorheriges finden, um zu weiteren gefundenen Instanzen zu springen.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/SearchObjectParameters.png 

Wenn Sie den Variablen in der Parameterliste Werte zuweisen, definieren Sie damit die Attribute eines bestimmten GDL-Objekts. Die hier zugewiesenen Werte werden im Einstellungen-Dialogfenster als Standardwerte angezeigt, wenn Sie ein Werkzeug auswählen, das GDL Objekte verwendet. Diese lokal definierten Parameter können auch von den verschiedenen Scripts des Objekts aufgerufen werden.

Die blau dargestellten Parameter sind obligatorische Parameter (wie z. B. A- und B-Bemaßungen), die zum Subtype des bearbeiteten Objekts gehören.

Optionale Parameter stehen zur Verwendung in der GDL-Beschreibung des Objekts zur Verfügung. Die für die optionalen Parameter definierten Werte werden als Standard-Zusatzwerte im jeweiligen Einstellungen-Dialogfenster angezeigt, das Sie über den Werkzeugkasten öffnen können.

Die zusätzlichen Parameter werden oft dazu verwendet, z. B. die Anzahl der Tür- bzw. Fensterfelder, die gängigen Oberflächenmaterialien eines Elements usw. festzulegen.

Durch Betätigen der Schaltfläche Neu im oberen Fensterbereich können neue Parameter erstellt werden. Wählen Sie zum Löschen bestehender Parameter die entsprechenden Einträge aus und klicken Sie auf die Schaltfläche Löschen, die sich neben der Schaltfläche Neu befindet.

Jeder Parameter in der Parameterliste kann in seiner eigenen Reihe editiert werden. Jede Zeile besteht – den Typ angebend -, aus einem Symbol (erforderlich), der Variablen des Parameters bestehend aus einem mehreren Buchstaben/Zeichen, einem beschreibenden Text (optional, aber empfohlen) und einem numerischen Wert.

Markieren Sie die Zeile, die Sie bearbeiten möchten. Der Variablenname oder das Typsymbol des obligatorischen Parameters kann nicht bearbeitet werden. Alle Elemente optionaler Parameter können bearbeitet werden.

Über die Typ-Symbole wird festgelegt, wie die Werte von ARCHICAD interpretiert werden. Wenn Sie auf ein Typ-Symbol klicken, wird eine PopUp-Palette angezeigt, in der Sie den Parametertyp durch Auswahl eines anderen Symbols nachträglich ändern können.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Integer.png 

Die Parametertypen sind für obligatorische und zusätzliche Parameter identisch. Folgende Typen stehen zur Verfügung:

Länge:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Length.png 

zur Angabe der physikalischen Abmessungen des GDL Objektes (und zur Konvertierung in beliebige verwendete Maßeinheiten) Dies muss eine positive Zahl sein.

Winkel:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Angle.png 

zur Angabe von Winkelwerten in Dezimalgraden für GDL-Operationen (z. B. Drehungen und Kreisbogendefinitionen)

Natürliche Zahl:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/RealNumber.png 

zur Angabe nichtdimensionaler Dezimalwerte (sämtliche natürlichen Zahlen), z. B. zur Verwendung eines Vergrößerungsfaktors in einer GDL-Berechnung.

Ganzzahl:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Integerpici.png 

zur Angabe ganzer Zahlen und nichtdimensionaler Werte (z. B. zur Definition der Anzahl identischer Bestandteile in einer GDL-Beschreibung oder der Anzahl von Durchläufen einer GDL-Programmschleife)

Boole’sche Operation:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Booleanpici.png 

Der Wert eines Booleschen Parameters kann nur 1 oder 0 sein. Boolesche Parameter werden z. B. zum Aktivieren und Deaktivieren von Aktionen oder Objekten innerhalb eines GDL-Objektes verwendet. Die Booleschen Werte können entweder durch direkte Eingabe in das Wertefeld oder durch Anklicken des Kontrollkästchens am rechten Ende der Parameterzeile eingestellt werden.

Text:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/abc.png 

zur Angabe von Zeichenketten von bis zu 255 Zeichen Länge. Dient z. B. zur Definition von Änderungen im GDL-Objekt oder zur Eingabe von Text anstelle von Zahlen im Wertefeld des Parameters.

Oberfläche:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Materialpici.png 

zur Angabe einer Oberfläche als GDL-Parameter.

Linientyp:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Linepici.png 

zur Angabe eines Linientyps als GDL-Parameter.

Schraffurmuster

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Fillpici.png 

zur Angabe einer Schraffur als GDL-Parameter.

Stiftfarbe:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Penpici.png 

zur Angabe einer Stiftfarbe als GDL-Parameter.

Hinweis: Wenn einer der Parametertypen Oberflächendefinition, Schraffurmuster oder Stiftfarben gewählt wird, erscheint am rechten Ende der Parameterzeile eine Schaltfläche, über die Sie eine Popup-Palette mit den entsprechenden Einstellungen aufrufen können. Sie können jedes Attribut wählen, das derzeit in ARCHICAD verfügbar ist.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/107_12.png 

Hinweis: Die verwendeten Parameter können je nach den GDL-Beschreibungen sowohl die 2D- als auch die 3D-Aspekte des Bibliothekselements beeinflussen.

Die Parametertypen wurden um zwei Optionen erweitert: Trennung und Titel.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Separatorpici.png     //helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Titlepici.png

Diese sind virtuelle Parameter. Sie dienen ausschließlich zur effizienteren und klareren Organisation der Parameterliste.

Zum Organisieren der Parameterliste stehen Ihnen außerdem die Symbole zur Listenformatierung zur Verfügung. Sie sind nur sichtbar, wenn ein Listeneintrag markiert wurde.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/lib_main_para_form.png 

Klicken Sie auf das Symbol Parameter ausblenden, um den markierten Parameter aus dem Parameter-Paneel im Dialogfenster Objekteinstellungen zu entfernen.

Mit dem Hierarchie-Symbol erstellen Sie eine Hierarchie innerhalb der Parameter. Wird eine Hierarchie erstellt, erscheinen die untergeordneten Parameter als Untereinträge der Parameterliste im Dialogfeld Objekteinstellungen. Um die Untereinträge ein- oder auszublenden, klicken Sie auf das kleine Dreieck neben dem übergeordneten Parameter. Der Typ des übergeordneten Parameters ist beliebig wählbar. Ein Parameter vom Typ Titel kann jedoch nicht untergeordnet werden.

Klicken Sie auf das Symbol Fett (B), um den Parameternamen fettgedruckt darzustellen.

Das vierte Symbol, Einzigartig (U) (sofern aktiviert) bedeutet, dass der aktuelle Parameter NICHT übertragen wird, wenn Sie die übrigen Parameter dieses Objekts an ein anderes Objekt übertragen.

Siehe Parametertransfer zwischen Objekten.

Sie können die Werte, die ein Parameter annehmen kann, einschränken, indem Sie eine Anordnung definieren.

Beim Markieren eines Mengeneintrags in der Parameterliste erscheint ein Button neben der Schaltfläche Parametertyp.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/lib_main_para_array.png 

Klicken Sie auf die Schaltfläche, um zwischen einem einzelnen Wert oder einer Werteliste und einer Anordnung zu wechseln. Wenn eine Anordnung angezeigt wird und Sie darauf klicken, wird das Dialogfenster Ansammlungswerte angezeigt.

Hinweis: Wenn die Ansammlungswerte für einen Parameter festgelegt worden sind, kann das Dialogfenster Ansammlungswerte durch Drücken der Schaltfläche Einstellen im unteren Fensterbereich geöffnet werden.

Klicken Sie auf die Schaltflächen Einfügen und Löschen, um Reihen und Spalten hinzuzufügen. Editieren Sie die Felder der Ansammlung, indem Sie auf die Felder klicken, dann geben Sie den Wert im Zahlenfeld rechts ein. Wenn der Variablentyp es gestattet, können Sie die Werte auch über ein Popup-Menü auswählen.

Um eine Zeile oder Spalte einzufügen oder zu löschen, wählen Sie die Schaltfläche, die die Zeile/Spaltenzahl zeigt, und drücken Sie dann Einfügen oder Löschen.

Migration

Klicken Sie auf die Schaltfläche Migration, um eine Tabelle zu öffnen, in der Sie Objekte einer älteren Version definieren können, die in das momentan geöffnete Objekt (neuere Version) migriert werden sollen.

Füllen Sie die Haupt-GUID eines älteren Objekts aus, das in dieses neue, momentan geöffnete Objekt migriert werden kann.

Tragen Sie eine Versionsnummer für das alte Objekt ein (normalerweise die Nummer einer früheren ARCHICAD-Version): Wenn das Projekt in der früheren Version zurückgesichert wird (und wenn “Bibliotheksobjekte zurück-umwandeln” unter Optionen im Dialogfenster Sichern als ausgewählt ist), wird dieses neue Objekt migriert in ein altes Objekt in der Migrationstabelle, der die entsprechende Versionsnummer zugewiesen wurde. Das Rückwärts-Migrationsscript berücksichtigt alle diese Reihen bis zum ersten nicht erfolgreichen Lauf.

Anmerkung: Wenn Sie 0 als Versionsnummer eingeben, überspringt die Rückwärts-Migration dieses Objekt.

Bestandteile

Klicken Sie diesen Button an, um die Bestandteile des aktuellen GDL-Objektes in dem Editierbereich anzuzeigen. Bestandteile definieren die Zusammensetzung des Objekts für die Verwendung in Listen- und Berechnungsfunktionen.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/GDLComponent.png 

Klicken Sie Neu, um einen neuen Komponenten zu erstellen.

DB-Set: Aktivieren Sie die Datenbank über dieses Popup-Menü.

Schlüssel: Wählen Sie aus diesem Popup-Menü einen Schlüssel.

Anmerkung: Dieses Popup-Menü ist nur verfügbar, wenn Ihre geladene Bibliothek Schlüsselbeschreibungen enthält.

Code: Definieren Sie einen Code für neue Bestandteile, oder modifizieren Sie den Code eines zuvor in diesem Feld markierten Bestandteils.

Menge: Definieren Sie eine Menge für neue Bestandteile, oder modifizieren Sie die Menge eines zuvor in diesem Feld markierten Bestandteils.

Einheit: Wählen Sie aus diesem Pop-Up-Menü einen Schlüssel.

Anmerkung: Dieses Popup-Menü ist nur verfügbar, wenn Ihre geladene Bibliothek Einheitenbeschreibungen enthält.

Proportional mit: Aktivieren Sie einen der vordefinierten GDL-Ausdrücke in diesem Pop-Up-Menü oder geben Sie durch Aktivieren des Buttons irgendeinen GDL-Ausdruck in dem langen Edit-Schaltfeld darüber ein.

Für Einzelheiten über die Bestandteile-Bearbeitung siehe das ARCHICAD Berechnungshandbuch.

Beschreibungen

Klicken Sie auf diese Schaltfläche, um die Beschreibungen des aktuellen GDL-Objektes im Bearbeitungsbereich zu zeigen. Beschreibungen definieren die Zusammensetzung des Objekts für die Verwendung in Listen- und Berechnungsfunktionen.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/Descriptor.png 

Klicken Sie Neu, um eine neue Beschreibung zu erstellen.

Verbindung mit Datenbank-Element: Klicken Sie diese Schaltfläche, um einen Bestandteil oder eine Beschreibung mit einer externen Datenbank zu verbinden, die zu den ausgewählten Datenbanken der geladenen Bibliothek gehört. Solange ein Bestandteil oder eine Beschreibung mit der ausgewählten Datenbank verbunden ist, kann es nicht bearbeitet werden. Um es zu modifizieren, klicken Sie die Schaltfläche “Verbindung zur Datenbank entfernen”, um den Bestandteil oder die Beschreibung loszuketten.

Verbindung ändern: Klicken Sie dies, um eine existierende Verknüpfung mit einer anderen externen Datenbank umzudefinieren.

Text: Klicken Sie diesen Button an, um das Dialogfenster für Beschreibungs-Langtext zu öffnen, welches den gesamten Beschreibungstext enthält.

Kurztext: Geben Sie in diesem Feld einen Kurztext für eine neue Beschreibung ein.

Für Einzelheiten über die Beschreibungen-Bearbeitung siehe das ARCHICAD Berechnungshandbuch.

Script-Schaltflächen

Über diese Schaltflächen können Sie Ihr GDL-Objekt programmieren. Wenn Sie auf die eigentliche Schaltfläche klicken, nehmen Sie die Bearbeitung im Hauptfenster vor. Wenn Sie auf das Fenstersymbol neben dem Script-Namen klicken, wird ein separates Fenster zum Eingeben oder Bearbeiten des Scripts geöffnet.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/ScriptWindows.png 

Das Master-Script wird jedes Mal ausgeführt, wenn eines der anderen Scripte ausgeführt wird. Der wichtigste Vorteil dieses Scripts besteht darin, dass vor dem Ausführen der anderen Scripte globale Variablen oder Operationen definiert werden können und auf externe Daten zugegriffen werden kann.

In dem 2D-Textfenster können Sie mit Hilfe der unter GDL verfügbaren Umwandlungsfunktionen und Elemente für zweidimensionale Räume ein 2D-Symbol mit parametrischer Funktionalität erstellen. Mit diesem Script wird die 2D-Komplettansicht des Objekts generiert.

Im Fenster 3D-Script können Sie die 3D-Beschreibung des GDL-Objekts aufrufen und bearbeiten. Mit diesem Script wird die 3D-Ansicht des Objekts generiert.

Mit dem Eigenschaften-Script können Sie Beschreibungen und technische Daten an das Objekt anhängen. Dazu verwenden Sie seine Variablen und die dazugehörigen GDL-Befehle und -Ausdrücke. Die Komponentenmengen (Gewicht, Preis, Farbe etc.) können entsprechend den Ausdrücken im Beschreibungen-Script berechnet und in die Listen aufgenommen werden. Um das individuelle Eigenschaften-Script im Einstellungsdialogfeld des Elements als Standard zu verwenden, klicken Sie die Als Grundeinstellung setzen-Schaltfläche oben im Fenster.

Hinweis: Wenn ein Eigenschaften-Script definiert wurde, werden die Listenbefehle dieses Script verwenden. Dies gilt auch dann, wenn zuvor Bestandteile und Beschreibungen in den entsprechenden Bereichen des Dialogfelds erstellt wurden.

Mit dem Parameter-Script können die verfügbaren Auswahlmöglichkeiten als Wert eines gegebenen Parameters definiert werden. So können Sie beispielsweise die Oberflächenauswahl für Tischplatten auf hölzerne Oberflächen begrenzen, oder die verschiedenen Oberflächenvarianten eines bestimmten Türmodells lassen sich über ihren Namen definieren.

Im Interface Script können Sie eine eigene Benutzeroberfläche für Ihre GDL-Objekte bestimmen, einschließlich der grafischen Erläuterung der zusätzlichen Parameter. Falls ein Interface-Script vorhanden ist, enthält das Einstellungsdialogfenster des betreffenden Bibliotheksabschnitts ein Paneel Individuelle Einstellungen. Um das individuelle Interface-Script im Einstellungsdialogfeld des Elements als Standard zu verwenden, klicken Sie die Als Grundeinstellung setzen-Schaltfläche oben im Fenster.

Vorwärts-/Rückwärts-Migrationsscripts: Klicken Sie auf die Schaltflächen Migration vorwärts oder Migration rückwärts, um festzulegen, wie die Migration der Parameter einer alten Instanz vorwärts zum aktuell geöffneten Element durchgeführt werden soll (bzw. rückwärts zu einem älteren Element).

Tastaturkürzel des GDL Script Fensters

Im oberen Bereich aller Scriptfenster stehen einige häufig verwendete Funktionen als Schaltflächen zur Verfügung.

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/CheckScript.png 

Klicken Sie auf die erste Schaltfläche, um die markierten Zeilen in Kommentartext zu verwandeln, der beim Ausführen des Scripts nicht berücksichtigt wird. Kommentartext wird durch ein Ausrufezeichen am Zeilenbeginn gekennzeichnet.

Hinweis: Sie können mehr als eine Zeile auswählen.

Die zweite Schaltfläche hat den entgegengesetzten Effekt: sie bewirkt, dass markierte Kommentarzeilen in ausführbaren Programmcode umgewandelt werden.

Klicken Sie auf die dritte bzw. die vierte Schaltfläche, um markierte Absätze im Textfenster mit Tabulatoren nach links bzw. nach rechts zu verschieben.

Die letzte Schaltfläche überprüft das GDL-Script im aktiven Fenster.

Hinweis: Wenn Sie in einem Script-Fenster arbeiten, sind alle diese Funktionen zusammen mit weiteren Bearbeitungsbefehlen des Script-Fensters ebenfalls als Befehle des Menüs Bearbeiten verfügbar.

Anmerkung: Die Eigenschaft-, Interface- und Parameter-Scripteditorfenster enthalten auch eine Vorschau-Schaltfläche, um eine Vorschau des individuellen Skripts zu zeigen.

2D-Symbol (graphisch)

Durch Klicken auf das 2D-Symbol wird im Hauptfenster eine neues Bearbeitungsfenster geöffnet.

Jedes in Ihrem Projekt positionierte GDL-Objekt wird auf dem Grundriss durch ein zweidimensionales Symbol repräsentiert. Sie können vorhandene Symbole bearbeiten oder mit der ARCHICAD-Standardauswahl und den 2D-Werkzeugen (Pfeil, Auswahlrahmen, Text, Schraffur, Linie, Kreis/Kreisbogen, Spline und Fixpunkt) ein neues erstellen. Außerdem haben Sie die Möglichkeit, Elemente aus dem 3D-Fenster hier einzufügen (vgl. das abgebildete Beispiel).

Das Symbol, das schließlich auf dem Grundriss erscheint, wird aus den Elementen dieses Fensters und dem 2D-Script (falls vorhanden) erstellt.

2D-Symbol-Anzeige (Fragmente)

Zum Anzeigen der Fragmente des 2D Symbols wählen Sie die Schaltfläche 2D-Symbol aus, und gehen Sie zu Optionen > Elementattribute > Ebenen-Einstellungen (2D-Symbol). Das erscheinende Listenfenster zeigt die Fragmente des 2D-Symbols, diese sind nützlich, um die graphischen Elemente, aus denen das Grundriss-Symbol des Bibliothekselements zusammengesetzt ist, zu verwalten.

Zum Umschalten der Sichtbarkeit der Ebenen des 2D-Symbols eines Objektes öffnen Sie das 2D-Symbolfenster, und drücken Sie die Tastenkombination Strg+L (das Tastaturkürzel für die Ebeneneinstellungen). Spezielle Ebenen-Einstellungen werden geöffnet, die sich ausschließlich auf das 2D-Symbolfenster auswirken.

Klicken Sie auf ein beliebiges Fragment, um es ein- oder auszublenden, oder verwenden Sie die Alle sichtbar/Alle ausblenden-Schaltflächen.

Hinweis: In verborgenen Fragmenten können keine neuen grafischen Elemente abgespeichert werden. Falls Sie im Dialogfeld des zum Bearbeiten des Symbols verwendeten Werkzeugs ein verborgenes Fragment auswählen, werden Sie aufgefordert, ein anderes Fragment auszuwählen oder das gewählte Fragment anzeigen zu lassen.

Sie eignen sich besonders gut dazu, Teile des Symbols auf einfache Weise zu vervielfältigen. So können Sie mit den verschiedenen grafischen Werkzeugen eine Zeichnung im 2D-Scriptfenster und einen 2D-Text in GDL erstellen, der über die Fragmentnummer auf diese Zeichnung verweist, und sie in mehreren unterschiedlichen Drehungen und Positionen in das endgültige Symbol einbinden.

Um das Fragment festzulegen, in dem Sie bei der Arbeit im 2D-Scriptfenster zeichnen, wählen Sie eine Nummer im Ebenen-Pop-Up im Einstellungsdialog des verwendeten Werkzeugs aus.

Vorschau

Im Vorschaufenster können Sie einem GDL-Objekt eine typische Grafik hinzufügen. Die wirkt sich in keiner Weise auf Verhalten oder Darstellung des Objekts im Projekt aus. Diese Vorschau wird als Standarddarstellung des Objekts im zugehörigen Dialogfeld für die Werkzeugeinstellungen sowie neben den in einem Suchfenster aufgelisteten Bibliotheksobjekten angezeigt.

So erstellen Sie die Vorschau eines neuen Objekts:

1.Platzieren Sie das Objekt im Projekt.

2.Aktivieren Sie das Objekt und öffnen das 3D-Fenster, um diese Auswahl zu sehen.

3.Gehen Sie zu Ansicht > 3D-Darstellungsmodus > Standort & Projektionsart. Wählen Sie eine Projektionsart und richten Sie einen Blickwinkel ein, der die typischen Merkmale des Objekts zeigt. Klicken Sie auf OK.

4.Öffnen Sie Fenstergröße festlegen (im Register 3D-Fenster oder im Kontextmenü). Setzen Sie Höhe und Breite des Fensters auf einen identischen Wert, um ein quadratisches Fenster zu erhalten.

5.Wählen Sie Dokumentation > Rendering, Animation etc. > Photorealistik-Einstellungen. Stellen Sie eine Bildgröße ein, die Sie später verzerrungsfrei als Vorschau einfügen können und wählen Sie einen neutralen Hintergrund für das Objekt (z. B. weiß für Himmel und Boden).

6.Bei noch ausgewähltem Objekt wählen Sie Dokumentation > Rendering, Animation etc > Photorealistische Darstellung. Ein Modellbild wird generiert.

7.Wählen Sie Bearbeiten > Alle Elemente aktivieren und anschließend Bearbeiten > Kopieren.

8.Wechseln Sie zurück in den Grundriss. Während das Objekt noch ausgewählt ist, wählen Sie Ablage > Bibliotheken und Objekte > Objekt öffnen. Dadurch wird das Hauptfenster des ausgewählten Objekts geöffnet.

9.Klicken Sie auf das Vorschausymbol, um das entsprechende Fenster zu öffnen, und wählen Sie Bearbeiten > Einsetzen.

10.Sichern Sie das GDL-Objekt.

Sie können auch andere Daten aus der Zwischenablage einfügen, z. B. ein Foto des tatsächlichen Objekts.

2D- und 3D-Ansichten des Objekts markieren

Über die beiden Ansicht-Buttons unten links können Sie die entsprechenden Ansichten des GDL-Objekts öffnen:

//helpcenter.graphisoft.de/wp-content/uploads/ac21_help/appendix-settings/2D3DView.png 

2D-Ansicht

Im 2D-Ansichtsfenster können Sie das auf dem Grundriss angezeigte Symbol überprüfen.

Falls ein 2D-Script definiert wurde, wird die 2D-Ansicht aufgrund dieses Textes berechnet. Dies ist auch dann der Fall, wenn das 2D-Symbolfenster Zeichenelemente enthält. Das 2D-Script kann jedoch auf 2D-Symbol-Fragmente verweisen.

Um den 2D-Symbol-Bearbeitungsmodus zu verlassen, schließen Sie das 2D-Symbol-Fenster, oder wählen Sie ein anderes Fenster aus: entweder über das Master-Dialogfenster oder das Menü Fenster.

3D-Ansicht

Dieses Fenster enthält eine 3D-Ansicht des GDL-Objekts, das aus dem 3D-Script umgewandelt wurde. Blickrichtung und andere Aspekte werden über Ansicht > 3D-Darstellungsmodus > 3D-Stile oder die 3D-Navigationspalette gesteuert.

Fenster schließen und Änderungen sichern

Beim Schließen des Hauptfensters werden Sie aufgefordert, Ihre Änderungen zu sichern. Wenn Sie auf Ja klicken, werden alle Bestandteile Ihres Objekts (2D-Symbol und -Text, 3D-Text, Kommentare und Vorschau) gesichert.

Sie können Objekte auch mit den Befehlen Sichern oder Sichern als aus einem Bibliotheksobjektfenster speichern. (In der 3D-Ansicht können Sie das Bild nur mit dem Befehl Sichern als sichern.) Nach dem Sichern können Sie im Grundriss oder im 3D-Fenster den Befehl Ansicht > Neuaufbau > Neu aufbauen wählen, um das geänderte GDL-Objekt zu betrachten.

Wenn Sie das Hauptfenster eines GDL-Objekts (Bibliothekselement) schließen, werden auch alle anderen Fenster des Objekts geschlossen. Sie werden gegebenenfalls aufgefordert, noch nicht gespeicherte Änderungen zu speichern.

Übereinstimmung zwischen 2D- und 3D-Beschreibungen

Das 2D-Symbol und die 3D-Beschreibung werden automatisch miteinander im GDL-Objekt verbunden. Es gibt keine integrierten Sicherungsfunktionen gegen geometrische Inkompatibilitäten zwischen beiden Komponenten. Der am häufigsten auftretende Inkompatibilitätsfehler besteht darin, dass das 2D-Symbol und die 3D-Form unterschiedliche Positionierungen oder Ausrichtungen in Bezug auf den Ursprung haben.

Gehen Sie folgt vor, um dieses Problem zu vermeiden:

1.Aktivieren Sie die 3D-Ansicht des GDL-Objekts.

2.Wählen Sie Aufsicht unter Ansicht > 3D-Darstellungsmodus > Standort & Projektionsart > Axonometrie-Einstellungen und legen Sie den Winkel auf 270° fest.

3.Wählen Sie Bearbeiten > Alle Elemente aktivieren und anschließend Bearbeiten > Kopieren. Aktivieren Sie das 2D-Symbol-Fenster des GDL-Objekts und wählen Sie Bearbeiten > Einsetzen. Die Aufsicht des Objekts wird daraufhin (als Drahtmodell oder Schattierung) in das Symbolfenster eingefügt. Es sollte mit den Bemaßungen und der Position des 2D-Symbols übereinstimmen.

4.Vergewissern Sie sich, dass das Symbol mit der 3D-Ansicht übereinstimmt, und wählen Sie anschließend Widerrufen. Die 3D-Linien werden daraufhin entfernt.

Sie können diese Funktion nutzen, um das 2D-Symbol automatisch durch ARCHICAD erstellen zu lassen. Sie brauchen nur zusätzliche Fixpunkte, Linientypen etc. hinzuzufügen. Die Vorgehensweise ist für Türen und Fenster die gleiche mit folgenden Änderungen:

Wählen Sie Ansicht anstatt Draufsicht (der Winkel sollte ebenfalls 270° betragen).

Es wird eine gespiegelte Ansicht positioniert. Markieren Sie die positionierten Linien, und spiegeln Sie sie an der Referenzlinie der Wand.

Hinweis: Beim Positionieren einer Drahtmodellansicht werden redundante Linien entfernt. Mit der Option Verdeckte Kanten erhalten Sie eine genaue Ansicht. Linien, die sich unter anderen Elementen befinden, werden jedoch nicht angezeigt.

Sie können die Kompatibilität zwischen dem 2D-Symbol und dem 3D-Modell eines Bibliothekselements auch sicherstellen, indem Sie eine parametrische Beschreibung im GDL für das betreffende Symbol erstellen.